zdly.net
当前位置:首页 >> python安装sCipy库出错 >>

python安装sCipy库出错

先安装Numpypip install Numpy

不要这样装了,把装的scipy文件夹从C:\Python27\Lib\site-packages中删掉,之后到http://www.lfd.uci.edu/~gohlke/pythonlibs/下载对应64位python3的版本,下载完成后解压,直接放入C:\Python27\Lib\site-packages中就可以import了.这个是国外大学编译好的库,不存在安装不成功的问题.

直接使用pip install安装需要电脑安装有C编译器,更为简单的方式是下载预编译的包,具体过程如下:1.在网页中 http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy 下载对应操作系统的预编译安装包,需要根据python版本是2.x还是3.x,系统是32位还是64位进行选择2.使用pip包管理器进行安装,在命令行中输入pip install 下载scipy安装包的路径

不要再用python IDLE 了,那样你会在现在的环境下陷入绝望的,使用Anaconda吧,只要把anaconda用好,安装什么的不用再找包了,只要写入 pip install

也可以用python自带的安装工具,pip install numpy scipy 等.如果没有pip的话,可以试试easy-install numpy scipy.打开cmd,在里面输入这些命令.不想自己一个一个装的话,最简单的方法是安装python(x,y)套装,也可以考虑enthought套装,都有完整的安装包.如果用linux也很方便,比如ubuntu下用sudo apt-get install python-numpy python-scipy python-matplotlib等.

一个基本可以应用到其他IDE、其他第三方库的通用安装方法如下:首先,确保在pip外,还安装了wheel库.如果没有:打开cmd,输入pip install wheel进行安装.此方法通过二进制文件安装第三方库,需要在安装前确定好能够安装的版本.确

应该是系统的问题,可能是安装文件和系统不匹配导致?其实如果想方便使用,特别是需要用numpy, matplotlib, scipy等库的时候,可以选择直接下载绿色版,portable python,baidu一下,然后下载解压后,添加环境变量即可使用.

首先要确认有没有安装wheel, 有了这个包才能安装whl格式的文件.如果没有安装的话,先pip install wheel确认下载的包对于的python版本和你电脑上的python版本一直哈.然后再pip install Pandas.whl最好在cmd里安装哈~

使用Anaconda集成开发环境,下载对应的版本,勾选需要的IDE和环境设置即可 安装库在Anaconda promot 里面使用pip或者conda install都可以

第1步 下载NumPy的SUPERPACK安装 numpy的-1.3.0rc2-win32的-SUPERPACK-python2.6.exe (直接下载网址,4782592字节).运行此安装程序 导致“无法安装.的Python 2.6版要求,这是不是在注册表中找到“. 更新:有一个实际的安

网站首页 | 网站地图
All rights reserved Powered by www.zdly.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com